The incident has been resolved. Please reach out to support if you have more questions.
Resolved
The incident has been resolved. Please reach out to support if you have more questions.
Identified
We are actively investigating the incident. We are working with our DNS provider to restore service as quickly as possible
Investigating
We are actively investigating the incident.