Monitoring
The incident has been resolved. We are working on syncing payroll connections that were missed during the outage period, and will update this page once that is completed.
Investigating
We are actively investigating the incident.
Investigating
We are actively investigating the incident.