The incident has been resolved. Please reach out to support if you have more questions.
Resolved
The incident has been resolved. Please reach out to support if you have more questions.
Investigating
We are currently experiencing a delay with sending automated client reminders. We are actively investigating the incident.