The incident has been resolved. Please reach out to support if you have more questions.
Resolved
The incident has been resolved. Please reach out to support if you have more questions.
Identified
We have identified the issue, and are working to resolve it.
Investigating
The CX platform is currently experiencing minor delays in payroll syncing and processing. We are actively investigating the incident.