Verification Emails are very delayed
Resolved·Degraded performance

The incident has been resolved. Please reach out to support if you have more questions.

Wed, Dec 3, 2025, 05:13 PM
(2 days ago)
·
Affected components
Updates

Resolved

The incident has been resolved. Please reach out to support if you have more questions.

Wed, Dec 3, 2025, 05:13 PM

Monitoring

We have implemented a resolution, and are actively monitoring it. It is due to a third-party outage and we are working closely with our vendor to resolve this issue as soon as possible.

Wed, Dec 3, 2025, 04:55 PM(17 minutes earlier)